[SOLVED] Android & Gradle error: Default interface methods are only supported starting with Android N (–min-api 24)

... Message{kind=ERROR, text=Default interface methods are only supported starting with Android N (--min-api 24):

Reason

You will receive the above error due to the missing “compileOptions” configuration in the AndroidManifest.xml file.

Solution

Add the missing configuration. Example below.

android {
...
  compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
...
}

If you enjoyed this post please add the comment below or share this post on your Facebook, Twitter, LinkedIn or another social media webpage.
Thanks in advanced!

0 0 vote
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments