[ROZWIĄZANY] Android & Gradle error: Default interface methods are only supported starting with Android N (–min-api 24)

... Message{kind=ERROR, text=Default interface methods are only supported starting with Android N (--min-api 24):

Powód

Powyższy błąd otrzymasz ze względu na brakującą konfigurację “compileOptions” w pliku AndroidManifest.xml.

Rozwiązanie

Dodaj brakującą konfigurację. Przykład poniżej.

android {
...
  compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
...
}

Jeśli spodobał Ci się ten post to zostaw proszę komentarz poniżej oraz udostępnij ten post na swoim Facebook’u, Twitter’ze, LinkedIn lub innej stronie z mediami społecznościowymi.
Dzięki!

Leave a Reply

avatar
  Subscribe  
Powiadom o
Close Menu